CROWD or JIRA users failed to login to Bamboo

Still need help?

The Atlassian Community is here for you.

Ask the community

You have delegated Bamboo user management to either Crowd or JIRA. Due to misconfiguration, users are not authenticated. You have made amendments  but still the authentication fails.

The atlassian-bamboo.log shows the following:

2013-07-16 07:47:22,334 WARN [qtp31522607-200] [BambooElevatedSecurityGuard] Validating CAPTCHA response
com.octo.captcha.service.CaptchaServiceException: Invalid ID, could not validate unexisting or already validated captcha
	at com.octo.captcha.service.AbstractCaptchaService.validateResponseForID(AbstractCaptchaService.java:146)
	at com.octo.captcha.service.AbstractManageableCaptchaService.validateResponseForID(AbstractManageableCaptchaService.java:367)
	at com.atlassian.bamboo.user.authentication.BambooElevatedSecurityGuard.performElevatedSecurityCheck(BambooElevatedSecurityGuard.java:56)
	at com.atlassian.seraph.filter.PasswordBasedLoginFilter.runAuthentication(PasswordBasedLoginFilter.java:111)
	at com.atlassian.seraph.filter.PasswordBasedLoginFilter.login(PasswordBasedLoginFilter.java:72)
	at com.atlassian.seraph.filter.BaseLoginFilter.doFilter(BaseLoginFilter.java:130)
	at com.atlassian.seraph.filter.BambooLoginFilter.doFilter(BambooLoginFilter.java:34)
	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1331)
	at com.atlassian.plugin.servlet.filter.IteratingFilterChain.doFilter(IteratingFilterChain.java:46)
	at com.atlassian.plugin.servlet.filter.DelegatingPluginFilter$1.doFilter(DelegatingPluginFilter.java:66)
	at com.atlassian.oauth.serviceprovider.internal.servlet.OAuthFilter.doFilter(OAuthFilter.java:55)
	at com.atlassian.plugin.servlet.filter.DelegatingPluginFilter.doFilter(DelegatingPluginFilter.java:74)
	at com.atlassian.plugin.servlet.filter.IteratingFilterChain.doFilter(IteratingFilterChain.java:42)
	at com.atlassian.plugin.servlet.filter.DelegatingPluginFilter$1.doFilter(DelegatingPluginFilter.java:66)

Cause

Because you have tried several login attempts, the authentication attempt information might have been corrupted.

Resolution

  1. Stop Bamboo
  2. Run this SQL query against your Bamboo database, start Bamboo again, clear your browser cache and try to log in again:

    DELETE FROM AUTH_ATTEMPT_INFO;
Last modified on Jul 17, 2013

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.