Elastic Agent does not mount a Volume to my Elastic Instance

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Symptom

When an Elastic Bamboo is configured to use an EBS snapshot the elastic agent will mount an EBS-volume that has been created before to the elastic instance. This volume will be populated with the contents of a snapshot. The relation is:

 snapshot 1 ---- * Volume 

Your AWS account lets you limit the maximum number {N} of volumes available.

If not enough volumes are available, i.e. are ready to mount, the elastic agent will not succeed to mount a volume to the elastic instance and will use the default bamboo agent home directory that will be empty after startup.

The instance will still work but you will experience longer build times.

Looking at your aws console will reveal some volumes that are linked to a snapshot but are not attached to an instance, for example i-b626b6df:/dev/sdh (attached). You will have 'dangling' volumes associated with snapshots that are still 'in use' and cannot be used by other elastic instances.

Causes

There are several reasons:

  • Bamboo has crashed or lost connection to the elastic instance
  • Bamboo was shut down without all running instances shutting down.

Diagnosis

Access your elastic instance via ssh and view the /tmp/setupEbsSnapshot.log file for any details.

Solution

Free up your accounts capacity by deleting some volumes that are not mounted to any active instance.
Remember to shut down elastic instances via Bamboo's Management Console.

Last modified on Jul 11, 2013

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