Elastic agent status stuck in Pending - AmazonHttpClient Unable to execute HTTP request: connect timed out
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
After creating a custom AMI, Bamboo is able to start the EC2 agent and from the AWS console it is identified as running however, it never progresses past the "Pending" state. The following log data is captured on the agent in bamboo-elastic-agent.out
:
Syncing Elastic Bamboo Agent files...
2016-08-24 21:15:41,794 INFO [main] [S3Sync] Syncing from: bamboo-agent-release-us-e1/5.12.2.1/7d847bfc46abc598ec795eacdb0ebf959084237678a2a0353b189525b42b108c/ to /opt/bamboo-elastic-agent
2016-08-24 21:15:51,039 INFO [main] [S3Synchroniser] Syncing s3://bamboo-agent-release-us-e1/5.12.2.1/7d847bfc46abc598ec795eacdb0ebf959084237678a2a0353b189525b42b108c/ to /opt/bamboo-elastic-agent
2016-08-24 21:15:51,039 INFO [main] [AmazonClients] Detecting bucket location for [bamboo-agent-release-us-e1]
2016-08-24 21:16:21,724 INFO [main] [AmazonHttpClient] Unable to execute HTTP request: connect timed out
java.net.SocketTimeoutException: connect timed out
...
Diagnosis
The two default security groups that Bamboo creates enable all outbound HTTP traffic – "ControlledByBamboo" and "elasticbamboo".
Cause
Amazon Virtual Private Cloud (VPC) doesn't automatically permit outbound traffic.
Resolution
If you've set up a VPC you must define an Amazon Simple Storage Service (S3) endpoint from your VPC:
http://docs.aws.amazon.com/AmazonVPC/latest/UserGuide/vpc-endpoints.html