Unable to run pre-bootstrap upgrade tasks as your support period has ended

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

 

Problem

After installing / starting Bamboo the following message is shown on the UI:

The following appears in the atlassian-bamboo.log

Bamboo bootstrap failed: Unable to run pre-bootstrap upgrade tasks as your support period has ended. Please contact Atlassian and https://support.atlassian.com

Cause

An expired key is being loaded by Bamboo during startup.

Resolution

This error happens when a customer has got 2 licenses on their account but the one that already expired loaded into their Bamboo.

The property below on your <Bamboo_Home>/bamboo.cfg.xml contains the license that already expired:

<property name="license.string"> (valid license value here) </property>

 

Here are the steps to fix this:

  • Stop your Bamboo instance
  • Backup the bamboo.cfg.xml file somewhere else in your file system
  • Login to MyAtlassian
  • Retrieve the valid license key
  • Copy and paste the new license key on the property below, overwriting the one that expired:

    <property name="license.string"> (valid license value here) </property>
  • Restart your Bamboo instance

 

Last modified on Aug 31, 2016

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