CSP-11042 - Search and dashboard load very slowly due to index timestamp not being updated

Product: Confluence

Environment

Operating System  
Affect Version/s 2.5.4
JVM  
Database  
Application Server Standalone

Error Message


Symptom

Searches are very slow, therefore viewing the dashboard is very slow, but otherwise performance is okay.
Probably only applies to Linux and maybe other Unix based systems.
Index Queue sometimes contains too many entries and entries that are too old

Diagnostics/Test

Check the .timestamp file in your Confluence home's index directory to see if it is up-to-date, and changing about once every minute.
Eg

$ ls -l your_confluence_home/index/.timestamp
-rw-r--r-- 1 username groupname 0 2007-08-21 17:37 index/.timestamp

If the date given is in the past, then the .timestamp is not being updated appropriately.
If the user listed is not the user that runs confluence, there's a good chance that is the problem.

Root Cause

http://jira.atlassian.com/browse/CONF-9228
The Java method Confluence uses to set the last modified date on the .timestamp file sometimes fails if it is not running as the owner of the file, even when the user does have permission to edit the file.

Solution

Delete the .timestamp file.

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