Administrator users from LDAP not able to create/edit filters or view avatars of other users

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Symptoms

Administrator users from LDAP directories are not able to create or edit filters in JIRA. They can search issues from the Issue Navigator but get error on saving the filter. They are also not able to view avatars of other users.

The following appears in Jira:

'xxx' does not have permission to access this page.

Cause

The JIRA administrator created by default has the JIRA Users global permission (as it belongs to the group jira-users be default) which is currently not the case for the LDAP user accounts which is set to have only the JIRA Administrators privilege (which do not grant the jira-users group membership by default). Some JIRA operations require that the JIRA Users global permissions is available for the user. One such example is editing of issue filters. This operation will throw the permission error shown above for the users account that only have JIRA Administrators permission.

Resolution

Add the users to users to the JIRA Users Global Permission, which by default is the jira-users group.

(info) Please see our Troubleshooting LDAP User Management documentation for further assistance with diagnosing LDAP problems.

Last modified on Nov 2, 2018

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