Cannot change to custom avatar
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
User are not able to change his/her avatar to custom avatar
- Only impacting single/some user
- Changing to default avatar works fine
- Other user are able to change to custom avatar
Diagnosis
Diagnostic Steps
- Trace the changing avatar using HAR file
- You will notice the username will point to 2 username
Cause
This is caused by conflicting username, for example:
- User John was rename to Jonathan and connected to LDAP
- A new user is created and uses the name John as user name
- Conflicting, JIRA will be confuse to map the avatar ID
Resolution
Rename the new user to use another login/username.