Issue created through Email does not have the expected Workflow Transitions

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

Using the Create a new issue or add a comment to an existing issue or the Create a new issue from each email message email handlers, newly created issues do not belong to the Issue Type expected. Because of this the following features might be incorrect:

  • Issue Fields
  • Workflow
  • Permissions
  • Screens

Diagnosis

To ensure that the problem is as described in this article, check the Mail Handler for an issueType setting. If it is absent, this article applies.

Cause

This is caused by JIRA defaulting to the first-listed Issue Type for the assigned project.

Resolution

  1. Open the Mail Handlers page from the Administration Console
  2. Click Edit for the Handler you wish to change
  3. Click Next
  4. Select your Issue Type
  5. Save the Handler parameters
Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.