JIRA does not write to atlassian-jira.log
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
The atlassian-jira.log file is not updated with the latest entries.
From the Administration >> System >> System Info
page, the Location of atlassian-jira.log shows as Could not find atlassian.jira.log.
Cause
There is insufficient file system permission for the user that runs JIRA to write on the file.
Resolution
Ensure the right file system permission is given to the user that runs JIRA.