JIRA throws error when trying to create new issues
Platform Notice: Server, Data Center, and Cloud By Request - This article was written for the Atlassian server and data center platforms but may also be useful for Atlassian Cloud customers. If completing instructions in this article would help you, please contact Atlassian Support and mention it.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When trying to create a new issue, JIRA throws the following error
Diagnosis
- Might be happening to specific type of projects (eg. Software project, Business project)
- Nothing is thrown in the logs
Cause
The affected project doesn't have any Standard Type task
In the example above, all Business type projects are affected (even newly created ones). From the screenshot, we can see that both issue types are sub-tasks
Resolution
Give the project a standard issue type
Single project
If only a single project is affected, create a new standard issue type and add it to the Issue Type Scheme the affected project is using
Business Projects
- Business projects use the Task and Sub-task type by default
- The problem arises when Task is modified to be a sub-task
- To resolve this, rename/delete the current Task (sub-task) and create a new standard issue type and name is Task