Jira User cannot add Watchers to an issue
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When one or more users try to enter a user's name in the Watchers field for an issue, the auto-complete functionality doesn't operate.
Diagnosis
This user will also be unable to use the @mention facility to mention users in comments.
Cause
This is caused by the user being denied the Browse Users privilege.
Resolution
Ensure the user involved has the Browse Users global permission, or is in a role that includes that permission.
More information can be found at Managing Global Permissions.
Note
If the Watchers field is missing from the issue view screen of any Jira issue, then it might be because the option Allow users to watch issues is disabled in ⚙ > System > General Configuration. If that's the case, you will need a Jira Administrator to re-enable this option.