No Option to 'Configure new SMTP mail server' after Upgrading to JIRA 4.3.x

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Symptom

When navigating to Administration >> Global Settings >> Mail Servers, there is no option to configure new SMTP mail server:

Causes

This could be caused by improper way of upgrade. There are some missing columns in the mailserver table

Diagnosis

The mailserver table should have these columns:


mysql> desc mailserver;
+---------------+---------------+------+-----+---------+-------+
| Field         | Type          | Null | Key | Default | Extra |
+---------------+---------------+------+-----+---------+-------+
| ID            | decimal(18,0) | NO   | PRI | NULL    |       |
| NAME          | varchar(255)  | YES  |     | NULL    |       |
| DESCRIPTION   | text          | YES  |     | NULL    |       |
| mailfrom      | varchar(255)  | YES  |     | NULL    |       |
| PREFIX        | varchar(60)   | YES  |     | NULL    |       |
| smtp_port     | varchar(60)   | YES  |     | NULL    |       |
| protocol      | varchar(60)   | YES  |     | NULL    |       |
| server_type   | varchar(60)   | YES  |     | NULL    |       |
| SERVERNAME    | varchar(255)  | YES  |     | NULL    |       |
| JNDILOCATION  | varchar(255)  | YES  |     | NULL    |       |
| mailusername  | varchar(255)  | YES  |     | NULL    |       |
| mailpassword  | varchar(255)  | YES  |     | NULL    |       |
| ISTLSREQUIRED | varchar(60)   | YES  |     | NULL    |       |
| TIMEOUT       | decimal(18,0) | YES  |     | NULL    |       |
+---------------+---------------+------+-----+---------+-------+
14 rows in set (0.00 sec)

Resolution

  1. Shut down JIRA.
  2. Refer to the diagnosis section above. If there is any missing column in the mailserver table, alter the table and add it manually.
  3. Restart JIRA and add the mail server.

Last modified on Feb 26, 2016

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