Blank page displayed when editing a permissions scheme in Jira server

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

 

Problem

When edit a permissions scheme, a blank page is shown. Results in the following exception in atlassian-jira.log : 

2016-04-22 12:37:01,622 http-nio-8080-exec-2 ERROR xxxx 757x4587x1 1aad55m 172.16.20.65 /rest/internal/2/managedpermissionscheme/10100 [c.a.p.r.c.error.jersey.ThrowableExceptionMapper] Uncaught exception thrown by REST service: null
java.lang.NullPointerException
	at com.atlassian.jira.permission.management.ManagedPermissionSchemeHelperImpl.buildGrants(ManagedPermissionSchemeHelperImpl.java:317)
	at com.atlassian.jira.permission.management.ManagedPermissionSchemeHelperImpl.lambda$generatePermissionSchemeBean$4(ManagedPermissionSchemeHelperImpl.java:224)
	at com.google.common.collect.Iterators$8.transform(Iterators.java:799)
	at com.google.common.collect.TransformedIterator.next(TransformedIterator.java:48)
	at com.google.common.collect.Iterators.addAll(Iterators.java:362)
	at com.google.common.collect.Lists.newArrayList(Lists.java:160)
	at com.google.common.collect.Lists.newArrayList(Lists.java:144)
	at com.atlassian.jira.permission.management.ManagedPermissionSchemeHelperImpl.generatePermissionSchemeBean(ManagedPermissionSchemeHelperImpl.java:238)
	at com.atlassian.jira.permission.management.ManagedPermissionSchemeHelperImpl.getManagedPermissionScheme(ManagedPermissionSchemeHelperImpl.java:104)
	... 2 filtered
	at java.lang.reflect.Method.invoke(Method.java:498)
	at com.atlassian.plugin.util.ContextClassLoaderSettingInvocationHandler.invoke(ContextClassLoaderSettingInvocationHandler.java:26)
	at com.sun.proxy.$Proxy264.getManagedPermissionScheme(Unknown Source)

Symptoms

  • After upgrading to Jira 7
  • After deactivating Jira Service Management

Cause

Cause 1

There seems to be an old permission type from the old version of Jira that is still present in this permission scheme.

Cause 2

Service Management's role is still being used in the permission scheme.

Resolution

Resolution 1

  1. Option 1 (if you can roll back the Jira upgrade) : While still on Jira 6 (or the version of Jira before upgrading), check the permission scheme on the UI. Notice that there is an 'Unknown Security Type' in there. 
    1. This security type is not compatible in the new version. So, it needs to be deleted. 
    2. If you can spot the problematic security type then delete that security type from the Jira version prior to the upgrade and then upgrade the Jira instance again.
  2. Option 2 (If you have upgraded already, and cannot roll back) : 
    1. Create a new permission scheme from the UI. Make sure it does not give the same error.
    2. Run the following queries in the database : 

      SELECT * FROM schemepermissions WHERE scheme=<old>
      SELECT * FROM schemepermissions WHERE scheme=<new>

      (info) Here 'old' and 'new' are ids of the permissions schemes. To determine the id for the permission scheme, hover over the permission scheme in Administration console. The id will show up in the url.  

    3. Comparing the results of the 2 queries should help to identify the perm_type that is causing problems.
    4. Deleting the rows that are causing problems :

      DELETE FROM schemepermissions WHERE perm_type="reportercreate"

      (info) In this case its "reportercreate". It could be different in other cases.

      Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

    5. Restart Jira. That should help to fix the issue here.

Resolution 2

Option 1

  1. Install Jira Service Management
  2.  > Issues > Permission Scheme
  3. Check the permission scheme with the name Jira Service Management Permission Scheme for Project XXX
  4. Remove *Service Management customer - portal access* from the permission schemes
  5. Uninstall Jira Service Management

Option 2

Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

  1. Update the database:

    delete from schemepermissions where perm_type = 'sd.customer.portal.only';
  2. Restart Jira.

 

 

Last modified on Nov 23, 2020

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