Replying JIRA Notification From Mobile Device Create New Issue

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Symptoms

A new issue will be created when replying JIRA notifications from mobile devices. However, replying to the same email from the desktop will add comment correctly to the issue. 

Diagnosis


  1. Trigger notification from JIRA instance
  2. Generate raw email in the .eml format from the reply sent from both desktop and mobile devices. 
  3. Compare the header and check if the "In-Reply-To" and "References" exist in the .eml file

Cause

This behaviour is caused by third-party application. The email replied from the mobile devices does not have the header "In-Reply-To" and "References" and thus JIRA not processing the email as comment.  There is also a bug in the stock Android Email App tracked at ID28017 that causes this behaviour.

Workaround

To ensure that replied added successfully as a comment, include the issue key in the email's subject.


Last modified on Apr 16, 2024

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