Dashboard gadgets display 404 or GadgetException errors in Jira server

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Symptoms

One or more gadgets can't be displayed in Dashboard with one of the below exceptions shown in Gadget window on the Dashboard:

Http status 404 - /plugins/servlet/gadgets/ifr
Error loading gadget: org.apache.shindig.gadgets.GadgetException: Unable to retrieve gadget xml. HTTP error 404

Causes and Resolutions

This issue could be caused by any number of reasons - please review each cause and solution in turn:

Cause 1

The problem is caused by an incorrect JIRA home setting and typically when JIRA home is set as same as "appBase" of Tomcat Host.

Resolution

  1. Shutdown JIRA
  2. Follow Setting your JIRA Home Directory to change the JIRA Home Directory. The JIRA Home directory should be different than the installation directory, or where the webapp is deployed.
  3. Restart JIRA

Cause 2

The problem is caused by SSL misconfiguration.

Resolution

  1. Make sure you are using a real certified secure certificate, not a self-signed one
  2. Reimport the certificate using the following command. You will need a .p7b and .jks file:
    1. keytool -import -trustcacerts -alias server -file <domainName>.p7b -keystore <domainName>.jks
  3. Add the following line to iptables:
    1. iptables -t nat -A OUTPUT -p tcp -d <IP Address> --dport 443 -j DNAT --to <IP address>:<port number>
    2. add an entry for your domain to point to the IP address (if JIRA and another product share the same VM)
  4. When testing, change the client's hosts file to point the SSL name to the IP address (for example - C:\windows\system32\drivers\etc\hosts)

Cause 3

The problem is caused by an application being down, plugin being removed, or plugin being out of date.

Resolution

  1. If the gadget relies on data from another system (E.G. Confluence, Fisheye, Bamboo), make sure that the related applications are up and running with no problems.
  2. If the gadget relies on data from a plugin, make sure that the plugin is operating properly, is not removed, and is not out of date.

Cause 4

The problem is caused to outdated indexes/corrupted work directory.

Do note that JIRA is required to perform a full re-index upon removing the indexes directory.  Therefore, we highly suggest to perform this suggestion during off office hours, as it needs a down time for JIRA to rebuild the indexes.

Resolution

  1. Shutdown JIRA
  2. Remove the content within the following directory:
    1. <JIRA-HOME>/caches/indexes/
    2. <JIRA-HOME>/plugins/.bundled-plugins/
    3. <JIRA-HOME>/plugins/.osgi-plugins/
    4. <JIRA-INSTALL>/work/
  3. Start JIRA again
  4. Re-index your JIRA instance

Other Causes and Solutions

  • An incompatible plugin in JIRA causes all gadgets to fail. For example the Atlassian JMX Monitoring Plugin has been known to cause issues.
    • Shutdown JIRA, remove the plugin from the installed-plugins folder, restart JIRA.
  • The problem is caused by running JIRA on a system that is not part of the Supported Platforms. Make sure that your OS, database, Java version, web browser, and application server are supported.
  • The problem was a bug in an old version of JIRA. Upgrade to the latest version of JIRA.
  • The problem is caused by running out of memory. Increase your memory allocation to 768MB or higher.
  • If nothing above helps, Please make a backup of your database and then try the workaround from this bug : GHS-9991 - Getting issue details... STATUS

 

Last modified on Sep 25, 2019

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