Supported platforms

This page describes the supported platforms for  Bamboo 7.2 .


Definitions:

(tick) Supported - you can use Bamboo with this platform.

(info) Limited - you can evaluate Bamboo on this platform, but you can't use it to run a production Bamboo site. 

(warning) Deprecated - support for this platform will end in an upcoming release.

Java

Oracle JDK:

(tick) Java 1.8

Open JDK:

(tick) Java 1.8

AdoptOpenJDK:

(tick) Java 1.8 (Hotspot JVM)

Good to know:

  • Once the JDK is installed, you will need to set the JAVA_HOME environment variable, pointing to the root directory of the JDK. Some JDK installers set this automatically (check by typing 'echo %JAVA_HOME%' in a command prompt or 'echo $JAVA_HOME' in a shell). You need to do this before installing Bamboo, as Bamboo will automatically configure JDK capabilities based on the system environment variables on your machine.
  • For Bamboo server, it is not enough to have just the JRE. Please ensure that you have the full JDK.
  • JVM implementations other than HotSpot are not supported, and JDKs from other vendors have not been tested.
  • You only need to run the agent and server using a supported JDK. Agents can build software with any JDK version. 


Operating systems

Operating systems:

Server

(tick) Microsoft Windows 

(tick) Linux

(warning) Solaris

(warning) MacOS / OSX

Agents

(tick) Microsoft Windows 

(tick) Linux

(tick) Solaris

(tick) MacOS / OSX



Good to know:

  • For Linux, you should create a dedicated user to run Bamboo. Bamboo runs as the user it is invoked under and can potentially be abused. See Installing Bamboo on Linux.
  • (warning) Solaris and MacOS are becoming deprecated for server and support for this operating system will end in coming releases. For agents the support for both of these operating systems remains unchanged. 

Databases

MySQL:

(tick) MySQL 5.7

(warning) MySQL 5.6.3

PostgresSQL:

(tick) PostgreSQL 12

(tick) PostgreSQL 11

(tick) PostgreSQL 10

(tick) PostgreSQL 9.6

Microsoft SQL Server:

(tick) SQL Server 2019

(tick) SQL Server 2017

(tick) SQL Server 2016

Oracle:

(tick) Oracle 19c

(tick) Oracle 12c R2

H2:

(tick) shipped with Bamboo

Good to know:

  • MySQL is supported when used with the JDBC Connector/J 5.1.   

    Supported only with the InnoDB storage engine.

  • PostgreSQL is supported when used with the JDBC driver bundled with Bamboo.
  • SQL Server is supported when used with  Microsoft's JDBC driver
  • Bamboo ships with a built-in H2 database.


    The H2 database fine for evaluation purposes but is somewhat susceptible to data loss during system crashes. For production environments we recommend that you configure Bamboo to use an external database.

  • Starting from version 7.0, we've stopped bundling the JDBC driver for Oracle with Bamboo. 
    • For Oracle 12c R2 and 19c, use the 12.2.0.x driver (ojdbc8.jar).

    • For Oracle 19c, you can use either ojdbc8.jar or ojdbc10.jar.


Bamboo doesn't support database environment clusters or SCAN VIP Adresses.

Web browsers

Web browsers:

(tick) Mozilla Firefox

(tick) Chrome

(tick) Safari

(tick) Microsoft Edge

Good to know:

  • If not specified otherwise, the latest stable version supported.



Source repositories

Git

(tick) 2.8 and later


Mercurial:

(warning)  1.8 - 5.6

Perforce

Subversion:

(tick) 1.5

(tick) 1.6

(tick) 1.7

(tick) 1.8

(tick) 1.9

(tick) 1.10

Good to know:

  • Bamboo 4.2, and later versions, support Subversion 1.7, but use the Subversion 1.6 Workspace Format by default to keep backwards compatibility with older Subversion working copies. You can set the bamboo.svn.wc.format system property if your Bamboo plans need to use Subversion 1.7 commands as part of your build scripts. See Setting Bamboo to Support Subversion 1.7 Workspace Format for details.

Docker

Docker for Mac:

(tick) 17.07 or later

Docker for Linux:

(tick) 17.07 or later


Infrastructure

Application servers:

  • Bamboo runs on a bundled Apache Tomcat and it's the only supported configuration.

Internet protocols:

  • You can run Bamboo in both IPv4 and IPv6 environments.
  • Raw IPv6 addresses are not always recognized. See the IPv6 in Bamboo for limitations and known issues. 

Agents and custom EC2 images:

Atlassian doesn't provide support for customized images. Bamboo provides flexibility to use customized machine images, but it's impossible for us to support all individual configurations.

Use Bamboo stock images as the base for all image customizations to ensure a minimal level of consistency of your Elastic Bamboo setup.

Last modified on Nov 2, 2021

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.