All Remote Agent disconnecting or Transport Connection errors

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Platform Notice: Server and Data Center Only - This article only applies to Atlassian products on the server and data center platforms.

     

Summary

Intermittent All Remote Agents drop from Bamboo.  Or intermittent Transport Connection Channel was inactive for too (>300000) long errors

Environment

Bamboo 7

Diagnosis

All Remote Agent intermittently drop from Bamboo and Intermittent errors in logs like the following:

WARN [ActiveMQ InactivityMonitor Worker] [Transport] Transport Connection to: tcp://10.10.10.10:49705 failed: org.apache.activemq.transport.InactivityIOException: Channel was inactive for too (>300000) long: tcp://10.10.10.10:49705

Cause

When Bamboo and a Remote Agent have a network issue, Bamboo checks every 5 minutes if the tcp session is still active.  Bamboo does not timeout the session for write operations.  Eventually the session does timeout dependant on other setting.  There are ways that Bamboo can restart the time even with no action.  

Solution

Adding transport.soWriteTimeout will allow Bamboo to shutdown the sessions if the TCP session has timed out.

* We now check dead transports every 90 seconds
* If something gets stuck in a socket write, now it will be timed out in 45 seconds.

What we are recommending:

<property name="bamboo.jms.broker.uri">tcp://0.0.0.0:54663?wireFormat.maxInactivityDuration=90000&amp;transport.soWriteTimeout=45000</property>


Still having problems?

Contact Atlassian Support. We'll be happy to advise you. Please include as much detail as possible, where applicable:

  • Logs from the affected application (if applicable)
  • Screenshots of the error message (if they're not covered in logs)
  • Information about the steps you've taken previously



Last modified on Mar 15, 2021

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