Builds fail due to JMS message listener failed with no converter available

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Build plans fail after upgrading to Java 11/Java 17 with the following error message:

atlassian-bamboo-agent.log
WARN [remoteEventRebroadcasterMessageListenerContainer-1] [AbstractMessageListenerContainer] Execution of JMS message listener failed, and no ErrorHandler has been set.
com.thoughtworks.xstream.converters.ConversionException: No converter available
---- Debugging information ----
message             : No converter available

Environment

Observed after upgrading Bamboo to 9.4 or newer versions.

Diagnosis

Build plans are unable to run and trigger the following error in the <bamboo-agent-home>/atlassian-bamboo-agent.log file:

atlassian-bamboo-agent.log
WARN [remoteEventRebroadcasterMessageListenerContainer-1] [AbstractMessageListenerContainer] Execution of JMS message listener failed, and no ErrorHandler has been set.
com.thoughtworks.xstream.converters.ConversionException: No converter available
---- Debugging information ----
message             : No converter available
type                : com.atlassian.bamboo.event.ServerFingerprintBroadcastEventV2
converter           : com.atlassian.bamboo.serialization.xstream.StrippingConverter
message[1]          : Could not initialize class net.sf.cglib.proxy.Enhancer
converter[1]        : com.thoughtworks.xstream.converters.reflection.ReflectionConverter
message[2]          : Unable to make field private static final long java.util.EventObject.serialVersionUID accessible: module java.base does not "opens java.util" to unnamed module @4eb6d1d0
version             : not available
-------------------------------
at com.thoughtworks.xstream.core.DefaultConverterLookup.lookupConverterForType(DefaultConverterLookup.java:88) ~[xstream-1.4.20.jar:1.4.20]

Cause

Performance enhancements have been observed across Java versions 8, 11, and 17, although some classes now require additional parameters to function optimally.  If the agent is not upgraded or manually updated as per the Bamboo remote agent installation guide, the properties outlined in the Solution section within the wrapper.conf file of the agent operating on Java 11 or Java 17 will not be updated and will result in the build plan being unable to execute. This will trigger the error detailed in the Diagnosis section.

Solution

When upgrading Bamboo from versions 8.0–9.3 to version 9.4 or later either download a new remote agent JAR from your upgraded Bamboo and reinstall the wrapper or update the wrapper configuration manually: Bamboo remote agent installation guide. This ensures that agents running on Java 11 or Java 17 can perform the necessary conversions effectively.

An workaround to solve this error is through the steps below:

  1. Stop the original agent.
  2. Open the wrapper configuration file <BAMBOO_AGENT_HOME>/conf/wrapper.conf.
  3. In the wrapper.conf file, replace the values for the following properties (or add them if they are not there):

    wrapper.java.version.min=11
    wrapper.java.version.max=17
    wrapper.java.version.fallback=11
    wrapper.java.additional.4=--add-opens=java.base/
    java.util=ALL-UNNAMED
    wrapper.java.additional.5=--add-opens=java.base/
    java.lang=ALL-UNNAMED
    wrapper.java.additional.6=--add-opens=java.base/
    sun.net.www.protocol.http=ALL-UNNAMED
    wrapper.java.additional.7=--add-opens=java.base/
    sun.net.www.protocol.https=ALL-UNNAMED
  4. Start the agent.


Last modified on Mar 14, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.