CVS checkout Terminated with fatal signal 11

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When checking out CVS repositories, the command fails and you receive the error

Finished command with an error org.netbeans.lib.cvsclient.event.TerminationEvent@<hash>[error=true]

 

If DEBUG logging is enabled for com.atlassian.bamboo.repository.cvsimpl, you will see the underlying error, Terminated with failed signal 11.

Cause

This is related to an error communicating with the CVS server.

At the time of writing, we know of two possible causes:

  1. The CVS server running out of virtual memory
  2. Incorrect casing in filenames on the CVS server:

    Scenario:

    • Bamboo hosted on a Windows server, where filenames are case-insensitive, saves file {{/cvs/module/File.java}}

    • CVS hosted on a Linux server contains {{/cvs/module/file.java}}

Resolutions

Cause 1: CVS server out of Virtual Memory

The Signal 11 that the error mentions is a Segmentation Violation (SIGSEGV). This means that the process is attempting to write to memory outside of what is allocated. If this was the case, please increase the virtual memory available to CVS.

Cause 2: Incorrect casing in filenames on the CVS server

In the scenario provided, the expected casing is file.java, and File.java is seen as a corrupted file.

Please delete File.java and check in the file with the correct casing (file.java).

Last modified on Feb 8, 2017

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