External user authentication is not working correctly for new users

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Symptoms

After adding some new users to the AD infrastructure, making sure that these accounts work fine elsewhere and are shown up properly under Administration > Users page, these users cannot login. Bamboo logs include this type of error messages:

2012-10-24 10:59:20,447 INFO [qtp63370617-11] [DefaultAuthenticator] login : 'user5' does not exist and cannot be authenticated.
2012-10-24 10:59:20,448 WARN [qtp63370617-11] [DefaultAuthenticator] login : 'user5' tried to login but they do not have USE permission or weren't found. Deleting remember me cookie.

Cause

Bamboo cache is corrupted.

Resolution

  1. Check the Crowd group that Bamboo installation is using and make sure the user that can't login is in that group, otherwise, add the user and try to login again.
  2. Stop Bamboo, run this SQL query against your Bamboo database, start Bamboo again and ask your user to log in again:

    DELETE FROM AUTH_ATTEMPT_INFO;
  3. Shut down the Bamboo instance, delete BAMBOO_HOME/caches directory, start the Bamboo instance.
Last modified on Jun 1, 2018

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