External user authentication is not working correctly for new users

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

After adding some new users to the AD infrastructure, making sure that these accounts work fine elsewhere and are shown up properly under Administration > Users page, these users cannot login. Bamboo logs include this type of error messages:

1 2 2012-10-24 10:59:20,447 INFO [qtp63370617-11] [DefaultAuthenticator] login : 'user5' does not exist and cannot be authenticated. 2012-10-24 10:59:20,448 WARN [qtp63370617-11] [DefaultAuthenticator] login : 'user5' tried to login but they do not have USE permission or weren't found. Deleting remember me cookie.

Cause

Bamboo cache is corrupted.

Resolution

  1. Check the Crowd group that Bamboo installation is using and make sure the user that can't login is in that group, otherwise, add the user and try to login again.

  2. Stop Bamboo, run this SQL query against your Bamboo database, start Bamboo again and ask your user to log in again:

    1 DELETE FROM AUTH_ATTEMPT_INFO;
  3. Shut down the Bamboo instance, delete BAMBOO_HOME/caches directory, start the Bamboo instance.

Updated on April 8, 2025

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