Mail server fails to send Email from Bamboo: dsn=5.6.0, stat=Data format error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When sending notification emails from Bamboo, the mail is dispatched properly to the mail server, but the email is not delivered and the following appears in the mail server log:

1 2 3 May 5 21:02:40 <hostname> sendmail[41797]: v45L2eFe041797: from=<from address>, size=521, class="-60", nrcpts=1, msgid=<message_id>, proto=ESMTP, daemon=MTA, at [127.0.0.1] May 5 21:02:41 <hostname> sendmail[41799]: v45L2eFe041797: to=<recipient>, delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=228521, relay=<relay_address>. [relay_ip], dsn=5.6.0, stat=Data format error May 5 21:02:41 <hostname> sendmail[41799]: v45L2eFe041797: v45L2fFe041799: DSN: Data format error

Cause

This issue occurs because the receiving server requires a real email address on a domain that it is able to look up.

Resolution

Please set a real, valid, email address as the From address in the Bamboo Mail server configuration.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.