Remote Agent disconnecting after 10 minutes because heartbeat status is not being updated

Still need help?

The Atlassian Community is here for you.

Ask the community

Problem

The atlassian-bamboo.log shows the remote agent sending heartbeats every 5 seconds:

2012-04-11 09:41:58,318 WARN [bambooHeartBeatMessageListenerConnector-2] [RemoteAgentManagerImpl] Heartbeat received from remote agent 'Windows Remote Agent' with time Wed Apr 11 09:41:58 EDT 2012 but last updated time was Thu May 10 10:28:14 EDT 2012. Status not updated...

However the remote agent keeps disconnecting and loading again, every 10 minutes:

Apr 10, 2012 11:10:59 AM A remote agent is loading on my.server.com (10.0.11.56).
Apr 10, 2012 11:11:52 AM Remote agent "my.server.com (2)" came back after a period of inactivity.
Apr 10, 2012 11:22:52 AM Remote agent 'Windows Remote Agent' was unresponsive and has gone offline.

Cause

The remote agent heartbeat is not being updated as there's a mismatch between the system time on the Remote Agent and system time on the Bamboo Server which is causing it to be ignored.

Resolution

Ensure both the system time between the Remote Agent and Bamboo Server are synced. It's advisable to keep them synced with an NTP service so that they cannot drift. The remote agent will need to be restarted if the system time has been updated on that end.

The Bamboo Server will retain the state of the most recent heartbeat timestamp (even if it's in the future), so if the timestamp retained from the agent was far in the future – it will keep ignoring heartbeats from the agent even after the times have been synced until the heartbeat is more recent than the retained one . To make Bamboo 'forget' this state, the Bamboo Server will need to be restarted.

Last modified on Jun 15, 2017

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.