Unable to configure agents in Bamboo due to "Method "reconfigure" failed for object"

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When trying to manage (disable, enable) a remote agent from the Bamboo User Interface, an Internal Server Error is displayed with a stack trace that contains the following error:

Method "reconfigure" failed for object

Environment

The solution has been validated in Bamboo 9.2 but may be applicable to other versions.

Diagnosis

When reviewing the <bamboo-home>/logs/atlassian-bamboo.log, the following error can be seen at the timestamp you try to configure the agent:

2024-06-26 14:02:31,396 ERROR [https-jsse-nio-8443-exec-66] [ExceptionMappingInterceptor] Method "reconfigure" failed for object [email]
ognl.MethodFailedException: Method "reconfigure" failed for object [email]
...
Caused by: java.lang.NoSuchMethodError: com.atlassian.bamboo.notification.NotificationRule.getNotificationType()Lcom/atlassian/bamboo/notification/NotificationType;
	at com.pronetbeans.bamboo.agentutils.AgentOfflineNotificationListener.handleEvent(AgentOfflineNotificationListener.java:81) ~[?:?]
...

Cause

The errors and the stack trace's caused by stem from the com.pronetbeans.bamboo.agentutils class, which belongs to a third-party, unsupported plugin: Agent Utilities - Basic.

The Agent Utilities - Basic app has been archived and is no longer supported by its vendor. It's Marketplace last modified date shows as 2013.

Solution

In order to fix this problem, please remove all the notifications related to this plugin from Bamboo administration > Overview > System notifications. This should be enough to let you disable/enable agents again without any errors.

It's also recommended to completely uninstall the plugin from Bamboo since it's no longer supported/maintained by its vendor.

Last modified on Aug 1, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.