Universal Plugin Manager hung installing add-on

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Symptom

UPM is hung install a plugin and the UI appears like below in Bamboo:

 

Cause

A installation record was not removed from the bandana table in Bamboo's database. You can verify this using the following database query which will return any plugin in the INSTALLING stage. 

SELECT * FROM BANDANA WHERE SERIALIZED_DATA LIKE '%INSTALLING%' AND BANDANA_KEY LIKE '%com.atlassian.upm.impl.PluginManagerPluginAsynchronous%';

Ensure Bamboo is shutdown when running query to avoid false positives. 

Resolution

Remove the INSTALLING record from the database and attempt to reinstall the application. 

tip/resting Created with Sketch.

It's always good practice to backup the database before editing!

  1. Stop Bamboo
  2. Backup database

  3. Run query to remove record:

    DELETE FROM BANDANA WHERE SERIALIZED_DATA LIKE '%INSTALLING%' AND BANDANA_KEY LIKE '%com.atlassian.upm.impl.PluginManagerPluginAsynchronous%';
  4. Start Bamboo
  5. Reinstall Add-on


Last modified on Nov 14, 2018

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