Bitbucket Server service installed as "BITBUCKET" instead of "Atlassian Bitbucket Server" and fails with code 4

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Service is installed as BITBUCKET instead of "Atlassian Bitbucket Server" and the service does not start with a message:

The following appears in the atlassian-bitbucket.log:

1 Windows could not start BITBUCKET on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service specific error code 4.

Cause

The service was installed with no administrator user

Resolution

  • Run command prompt as administrator

  • Run "service.bat remove" to remove the incorrect server

  • Run "service.bat install" to install the service correctly in the server

Updated on April 11, 2025

Still need help?

The Atlassian Community is here for you.