Bitbucket server shows "You've switched users" error message when managing account

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When making any change in the Manage Account page e.g. SSH keys or Notification settings it shows an error message "You've switched users"

The following appears in the Error message.

You've switched users 
You logged out as <user> and logged in as <anotherUser>.Please refresh the page to avoid seeing inconsistent  information

Popup message as below:

Cause

If the Bitbucket server is running behind a reverse proxy, this issue may be related to proxy's caching settings for the Bitbucket Server URL. To confirm, try accessing Bitbucket server bypassing the reverse proxy.

Workaround

Bypass the reverse proxy as mentioned in  How do I bypass a proxy for Bitbucket Server 

Resolution

Check the reverse proxy caching settings for Bitbucket server URL and disable it. 

 

Last modified on Nov 2, 2018

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