"SSO 2.0" menu item is not visible in the Administration page after upgrading from Bitbucket Server to Data Center

Still need help?

The Atlassian Community is here for you.

Ask the community


Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The "SSO 2.0" menu item is not visible in the Administration page after upgrading from Bitbucket Server to Data Center.

A Bitbucket Data Center license has been applied but the "SSO 2.0" link is still not available.

Links for other Data Center features, such as "Clustering" and "Mirrors" are available.

Environment

Bitbucket Server instance that was upgraded to Data Center.

Diagnosis

Manage apps

Look for the "SSO for Atlassian Data Center" or "SAML for Atlassian Data Center" in the list of installed apps and check its status.

  1. Go to Administration > Manage apps
  2. Select "All apps" in the dropdown
  3. Look for "SSO for Atlassian Data Center" or "SAML for Atlassian Data Center"
  4. Check if the plugin is currently disabled

Logs

The key for the plugin is com.atlassian.plugins.authentication.atlassian-authentication-plugin.

The $BITBUCKET_HOME/log/atlassian-bitbucket.log file will show that after the latest restart, the plugin is installed:

2021-03-03 15:03:33,106 INFO  [FelixDispatchQueue]  c.a.p.o.c.f.FelixOsgiContainerManager Installed bundle com.atlassian.plugins.authentication.atlassian-authentication-plugin (105)

However, there is no log entry stating that the plugin has been enabled. Searching for the string "'com.atlassian.plugins.authentication.atlassian-authentication-plugin' is now ENABLED" would not show any matches. There are no errors or warnings in the logs.

Here's a sample log entry that indicates that the plugin was enabled.

2021-03-03 20:06:20,929 INFO  [spring-startup]  c.a.plugin.manager.PluginEnabler Plugin 'com.atlassian.plugins.authentication.atlassian-authentication-plugin' is now ENABLED


Solution

Re-enable the plugin:

  1. Go to Administration > Manage apps
  2. Select "All apps" in the dropdown
  3. Look for "SSO for Atlassian Data Center" or "SAML for Atlassian Data Center"
  4. Click "Enable"
  5. Check that the "SSO 2.0" menu item is now available


Last modified on Jun 28, 2021

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.