When deleting a project, Server Unreachable message appears

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptom

When attempting to delete a project in Bitbucket Server, you get the message:

Server Unreachable

The server didn't respond. You may retry your request when the server comes back up.

Cause

Bitbucket Server provides a REST API that responds to GET, POST, PUT, and DELETE requests; but some firewalls are configured to not accept anything but GET and POST.

If you examine the HTTP response from the deletion attempt, you will notice that a 502 Bad Gateway error is being returned to the browser. In fact, that error code is not being returned by Bitbucket Server, but by a firewall or proxy server that is intercepting requests on their way to the Bitbucket Server instance.

Fix

Configure the intercepting firewall or proxy server so that it does not block HTTP DELETE requests for Bitbucket Server. For instructions on performing that configuration, see the operation manual for the particular firewall or proxy server product.

Last modified on Sep 16, 2015

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.