Unable to make the bulk upload via CSV on authentication policies, throwing the error "Unable to find some members"

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

 

Summary

Unable to make the bulk upload via CSV on authentication policies, throwing the error "Unable to find some members".
When adding users manually to a non-default authentication policy, the bulk option to upload a CSV with the emails is throwing an error saying it is not capable of finding the managed accounts. Yet, the users can be found under managed accounts.

Environment

Atlassian Access

Diagnosis

Analyzing the network requests using the browser developer tools or an exported HAR file, the same error is returned on the response payload for this HTTP request:

Request URL

https://admin.atlassian.com/gateway/api/admin/private/org/<org_id>/auth-policy/<policy_id>/add-users/csv

Response payload

{
	"code": "USER_NOT_FOUND",
	"message": "Some of the users does not exist"
}

Cause

The CSV might have been generated with a hidden special character for one of the users.

Solution

Copy the content of the CSV file into a new file, if the file sizes are different, the special character did not come together, use this file for the bulk upload.

  • If the sizes are still the same, you can use an editor like Nano to find the special character and remove it, or else, re-generate the file again from the same application or a different one.

Last modified on May 14, 2021

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