Users not redirected to SSO for authentication with Azure

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Users are not redirected to SAML SSO authentication and Atlassian Guard features like SAML SSO authentication / User provisioning not working.

Environment

This KB applies to organizations that had Atlassian Guard configured and integrated SAML Single Sign-On / User provisioning with Azure

Diagnosis

Atlassian Guard features like SAML SSO authentication and User provisioning not working due to Atlassian Guard subscription deletion. This can be confirmed by logging in to admin.atlassian.com and choosing your organization, then going to Billing. If you had an Atlassian Guard subscription and is not listed under billing now it means the subscription has been deleted.

Cause

Deletion of Atlassian Guard subscription. The subscription may be deleted due to non-payment or if payment methods are not updated. Atlassian sends email notifications to billing contact before the Atlassian Guard subscription is deleted.

Solution

Activate a free trial of the Atlassian Guard subscription by logging in at admin.atlassian.com and choosing your organization. Once the trial subscription is activated, enable back SAML SSO and user provisioning features.

Enable SAML SSO

  1. The configuration for SAML SSO is not deleted on the Atlassian Guard subscription deletion. At your Atlassian organization navigate to Security > SAML single sign-on and confirm the configuration for SAML is intact.
  2. Navigate to Security > Authetication policies > Select the policy that had SSO enabled > Edit > Check "Enforce Single sign-on" > Update
  3. This will enable back SAML SSO for your organization.

Reconfigure User provisioning

  1. The directory for user provisioning gets deleted with the deletion of the Atlassian Guard subscription. So, create a new directory by navigating to Directory > User provisioning > Create Directory at your Atlassian organization.
  2. Copy and save the directory URL and the API token created at step 1 
  3. Update the new directory URL and API token at the Atlassian Cloud application on Azure. This can be done at Azure by navigating to the Atlassian Cloud application > Provisioning > Edit provisioning > Admin Credentials.
  4. Enter the new creds, and click "Test connection".
  5. As the test connection is successful, Save the configuration.
  6. Under provisioning now click on "Restart provisioning", this will schedule provisioning to run and will sync the assigned groups/users to Atlassian.

Once provisioning of groups is completed it may run in group conflict as Azure will try to sync groups that already exist at your site. You may need to Resolve Group Conflicts so that the Groups in the Cloud Site are relinked with Azure

Update Atlassian Guard billing details to avoid subscription deletion in future

  1. Go to Billing > Atlassian Guard > Billing details.

  2. Click Update billing details to add a credit card, billing address, and billing contact details.

  3. Confirm your billing address and click Next.

  4. Chose your preferred payment method and click Next.

  5. Accept the terms and conditions and click Subscribe.

You'll be redirected back to the Billing details page once your subscription for Atlassian Guard has been processed successfully. 

(info) If you are paying for existing Atlassian cloud products and services, you still need to add your billing details for Atlassian Guard in the billing section of your organization.

(info) If your organization account is under external partner management, reach out to your partner to get the Atlassian Guard billing details updated.

Last modified on Feb 28, 2025

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