After upgrading Confluence, the following error appears in the logs 'Unable to resolve com.atlassian.confluence.plugins.templates'

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Server and Data Center Only - This article only applies to Atlassian products on the server and data center platforms.

    

Summary

Templates provided by user-installed plugins, if not updated, may become incompatible with newer versions of Confluence generating errors. This problem may occur after upgrading Confluence.

Environment

This problem was identified in Confluence server and datacenter version 7.4. It could also affect other versions of Confluence.

Diagnosis

The following appears in atlassian-confluence.log:

2021-01-09 07:13:06,745 ERROR [FelixDispatchQueue] [osgi.container.felix.FelixOsgiContainerManager] fram
eworkEvent Framework error in bundle com.atlassian.confluence.plugins.templates-dev
org.osgi.framework.BundleException: Unable to resolve com.atlassian.confluence.plugins.templates-dev [28
9](R 289.0): missing requirement [com.atlassian.confluence.plugins.templates-dev [289](R 289.0)] osgi.wi
ring.package; (osgi.wiring.package=com.atlassian.confluence.plugin.templates.export) Unresolved requirem
ents: [[com.atlassian.confluence.plugins.templates-dev [289](R 289.0)] osgi.wiring.package; (osgi.wiring
.package=com.atlassian.confluence.plugin.templates.export)]
...
2021-01-09 07:13:06,618 ERROR [FelixDispatchQueue] [osgi.container.felix.FelixOsgiContainerManager] fram
eworkEvent Framework error in bundle com.atlassian.confluence.plugins.templates-hr
org.osgi.framework.BundleException: Unable to resolve com.atlassian.confluence.plugins.templates-hr [290
](R 290.0): missing requirement [com.atlassian.confluence.plugins.templates-hr [290](R 290.0)] osgi.wiri
ng.package; (osgi.wiring.package=com.atlassian.confluence.plugin.templates.export) Unresolved requiremen
ts: [[com.atlassian.confluence.plugins.templates-hr [290](R 290.0)] osgi.wiring.package; (osgi.wiring.pa
ckage=com.atlassian.confluence.plugin.templates.export)]


Cause

The template apps have been archived and are no longer compatible with Confluence 5.1.5, 5.5.7, or later versions

Solution

 Refer to Uninstalling apps to remove the incompatible apps. To uninstall an app:

  1. From the top navigation bar in your application, choose  > Add-ons or Manage apps 
  2. Find the app you want to uninstall, and choose Uninstall.
  3. A notice appears indicating that the app was successfully uninstalled.


Last modified on Mar 30, 2021

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.