Attachments inaccessible after importing XML backup
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
After importing data using the XML backup, accessing attachments returns a file not found error.
The following appears in the atlassian-confluence.log
:
2010-05-26 19:30:04,981 INFO [Importing data task] [confluence.upgrade.upgradetask.DefaultSpaceContentUpgradeTask] doUpgrade Upgrade task complete.
2010-05-26 19:30:10,600 INFO [Importing data task] [confluence.importexport.actions.ImportLongRunningTask] runInternal Finished import.
2010-05-26 19:30:10,885 ERROR [Indexer: 10] [atlassian.confluence.pages.DefaultAttachmentManager] getAttachmentData Could not find data for attachment: Attachment: yourAttachment.doc v.1 (3538959) admin - java.io.FileNotFoundException: /var/opt/confluencehome/attachments/ver003/7/0/7/188/2/2938/3538959 (No such file or directory)
-- referer: http://confluenceURL/setup/setup-restore-start.action | url: /setup/setup-restore.action | userName: anonymous | action: setup-restore
The following import-related error appears in the atlassian-confluence.log
:
2010-06-02 17:36:32,133 ERROR [Importing data task] [confluence.importexport.xmlimport.BackupImporter] restoreDirectory Couldn't restore directory from backup! src: /var/opt/confluencehome/temp/import_06022010_172924/attachments/3312722/3539065 dest: /var/opt/confluencehome/temp/import_06022010_172924/attachments-new/3312722/3539065
– referer: http://confluenceURL/admin/backup.action | url: /admin/restore-local-file.action | userName: admin | action: restore-local-file
Cause
Confluence does not have write permission to its <confluence-home>/temp
folder. It needs to unzip attachments from the old backup first before it can save them to the designated location.
Resolution
- Make sure that Confluence has read and write access to its home directory.
- On Linux instances follow the chown and chmod in Creating a Dedicated User Account on the Operating System to Run Confluence
- In Windows, use the Replace all child object permissions with inheritable permissions from this object functionality on the home and install directories to recursively apply read and write permissions for the user running the Confluence process
Check the How to resolve missing attachments in Confluence utilities for physically lost attachments.