Calendar Does Not Show Up In Search Result

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Symptoms

After an upgrade to 5.4.1, there is calendar that does not show up in search result (when trying to search and add for existing calendar) although the calendar exist and has no restrictions. The calendar only shows up for the owner but not for other users. Manually subscribing to the .ics link helps to allow other users to start seeing the calendar and its events once again however the calendar becomes read-only (although there is no restrictions applied).

Rebuilding indices from scratch did not make any difference and other search functionality in Confluence is working just fine. 

Cause

The cause is still unknown.

Resolution

Export the calendar to iCal, delete the calendar and re-import it again. This seems to have resolved the issue. Other users can now find the calendar from the search result and it is not in read-only mode.

Last modified on Nov 15, 2018

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