How to enable Team Calendars in Confluence Data Center after migration from Server
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After migration from the Confluence Server to the Confluence Data Center, it has been noted that Team Calendars is deactivated in the application settings.
Environment
Confluence Data Center 7.19.18
Diagnosis
The Team Calendars app is now bundled with Confluence Data Center since February 1, 2021
Team Calendars app will be integrated with versions 7.11+ of Confluence DC out of the box, but you can get the bundle to work on previous versions as well.
This means not needing to manage a separate license for the app since it is now tied to the Data Center one.
For more details please refer to How to get Team Calendars bundled with an existing Data Center instance
Team Calendars for Confluence is now part of Confluence Data Center , for more details refer to Team Calendars
After migration from Confluence server to Confluence Data Center if Team calendars is disabled
From the top navigation bar in your application, choose Apps> Manage apps
Find the app "Team Calendars" you want to check , make sure drop down next to it has System selected as shown below


Solution
If you wish to utilise Team Calendars in Confluence Data Center, please ensure that the Team Calendars app is enabled as shown below.

For further information regarding the process of Disabling and enabling apps, please refer the article Disabling and enabling apps
Was this helpful?