JavaScript Browser Errors
Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
If your web browser is complaining about JavaScript errors or functions not being defined, then it is possible that you are not retrieving the latest versions of pages from your Confluence instance.
The Rich Text Editor does not load up correctly.
Cause
There are several causes:
- An invalid entry in the browser cache.
- Interference by antivirus software. For example, it has been reported that NOD32 antivirus software can attempt sanitation of some confluence javascript when that javascript is served by IIS.
- If you are using Internet Explorer 7 or 8, you may have hit the Stylesheet Limitation by having too many plugins enabled on Confluence.
Resolution
To fix this, clear your browser cache. Follow the instructions for your particular browser:
- Internet Explorer: How and Why to Clear Your Cache
- Firefox: How to clear the cache
- Safari: Safari: Clear Cache
- Chrome: Delete your cache and other browser data
Try to disable unused plugins and/or enable plugin support mode.