Load balancer health checks fail after upgrading Confluence
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Load balancer health checks are failing after upgrading Confluence.
Environment
Confluence Data Center 6.10+
Diagnosis
The following error message is thrown in <install-directory>/logs/catalina.out:
catalina.out
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09-Sep-2020 12:19:55.882 INFO [http-nio-8080-exec-27] org.apache.coyote.http11.Http11Processor.service Error parsing HTTP request header
Note: further occurrences of HTTP request parsing errors will be logged at DEBUG level.
java.lang.IllegalArgumentException: Invalid character found in the request target. The valid characters are defined in RFC 7230 and RFC 3986
Cause
Upgrading Confluence to version 6.10 also changes Tomcat version from 8 to 9. Tomcat 9 is more restrictive with HTTP request contents. There are a number of characters that are now restricted. This includes but is not limited to: " < > [ \ ] ^ ` { | } and spaces.
A similar issue is reported on this StackOverflow thread: StackOverflow Tomcat 9: header line does not conform to RFC 7230
Solution
Remove the problematic characters from the HTTP health check request performed by the load balancer.
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