Missing "Edit" button in certain External User Directories

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

In the User Directories Administrator page, the configuration settings of some of the external user directories are not able to be reconfigured due to the "Edit" button appears to be missing.

Cause

The reason that the "Edit" button is missing is that you are logged in to Confluence using a user from this User Directory.

Resolution

  1. Ensure that Confluence Internal Directory is at the Top order. This is to ensure that the user you are logging in with comes from Confluence Internal Directory, should duplication of the user exists throughout User Directories.
  2. Ensure that you are logged in to Confluence using an Administrator account that has Confluence Internal Administrator privileges.

Identifying Internal Confluence Administrator

To find out which usernames have Confluence Internal Administrator privileges, connect to your database using a database admin tool such as DBVisualiser. Download a database admin tool now if you don't have one installed already. Then connect to your database and retrieve the list of administrator usernames and IDs with:

select u.id, u.user_name, u.active from cwd_user u
join cwd_membership m on u.id=m.child_user_id join cwd_group g on m.parent_id=g.id join cwd_directory d on d.id=g.directory_id
where g.group_name = 'confluence-administrators' and d.directory_name='Confluence Internal Directory';
Last modified on Jun 7, 2018

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