No Data on Global Activity or Site Statistics Page For Some Days

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Symptoms

When viewing Site Statistics (Global Activity page), there are no data on a certain day even though there's a user activity.

The following appears in the atlassian-confluence.log:

2015-01-07 04:40:04,878 ERROR [http-8087-1] [ext.usage.event.UsageTaskQueue] rejectedExecution Discarding usage event(s) because task queue is full. Usage statistics may not be accurate.
 -- url: /display/TEST/DAILY+REPORT | userName: anonymous | action: viewpage | page: 24118500

Diagnosis

Perform the following to see if the missing data is caused by corrupted index:

Cause

The Usage Plugin does not scale for large indexes. Some indexing operations can cause hangs. The activity plugin does not perform well on sites with large amounts of traffic, especially when a large volume of activity data has been accumulated. The activity plugin uses a simple QueueExecutor which is queue of work handled by a single thread. It's not possible retrieve the activity data when it's failed to be stored in the index directory.

Resolution

Track Unable to locate Jira server for this macro. It may be due to Application Link configuration. and Unable to locate Jira server for this macro. It may be due to Application Link configuration. for improvement in this area.

Last modified on Mar 30, 2016

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