Plugins stopped working with the error message "Could NOT parse license type code"

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After migration, plugins stop working and the following error messages appear:

Could NOT parse license type code

 

The following appears in the atlassian-confluence.log

referer: https://<base_URL>/admin/calendar/reindexcalendarcontenttype.action | url: /rest/calendar-services/1.0/calendarcontenttype/reindex | traceId: 03bed222f729990b | userName: confluenceadmin

2017-11-25 10:48:46,850 ERROR [http-nio-8090-exec-6] [atlassian.plugin.web.DefaultWebInterfaceManager] filterFragmentsByCondition Could not evaluate condition 'com.atlassian.confluence.extra.calendar3.condition.ShowTimezoneSelectCondition@39b836d' for descriptor: com.atlassian.confluence.extra.team-calendars:show-timezone-setup (A flag that indicates if the current user should be shown the timezone setup dialog)

com.atlassian.extras.common.LicenseException: Could NOT parse license type code

Cause

The error message indicates that there's an issue with the Confluence license

Diagnosis

If you go to confluence.cfg.xml, there are extra characters "&gt;" found under the License property: 

<property name="atlassian.license.message">&gt;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx</property>

Resolution

Update the Confluence license with the correct Confluence license.

A restart might be needed.

 

Last modified on Nov 2, 2018

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