Removing Watches for a Deleted User

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

An undeliverable email is sent to a deleted user.

Cause

Proper deletion is done by dissociating a user from any can-use permissions. If a user has been removed from the database, their notifications may persist.

Resolution

Deactivate the user in your Confluence instance. If it doesn't help, you can manually remove notifications from the database by using the following SQL query:

For Confluence prior to release version 5.2.x

DELETE FROM NOTIFICATIONS WHERE username = '<user's name>';

For Confluence 5.2.x and above

DELETE FROM notifications WHERE username IN (SELECT user_key FROM user_mapping WHERE username= '<user's name>');

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.