Team Calendar is not working properly due to disabling Share Page system plugin
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
The symptom of this problem is that calendar view gets broken like below, though Team Calendar plugin is enabled.
There are no messages in application logs, and no errors in HAR file. However, if you check console messages of development tools in browser, you may find below error. It indicates this problem may be related to Share Page plugin.
batch.js?locale=ja-JP:434 Uncaught Error: tc/subcalendar-navigation-buttons-view missing confluence/share-page/service/share-page
at e (batch.js?locale=ja-JP:434:2107)
Cause
The customer may disable Share Page system plugin for some reasons, it will trigger this problem.
Solution
Search Share Page plugin in Manage apps page.
If it is disabled, enabling it will fix this problem.