Team Calendars for Confluence fails to load with "Team Calendars for Confluence: 500 - Transaction rolled back because it has been marked as rollback-only"
Symptoms
You are on Confluence <5.3 and have Team Calendars for Confluence installed.
You get
"Team Calendars for Confluence: 500 - Transaction rolled back because it has been marked as rollback-only" and the following stacktrace appears in atlassian-confluence.log
2014-01-16 09:09:28,491 ERROR [http-8090-47] [atlassian.confluence.security.DefaultSpacePermissionManager] hasPermission Error checking permission (). Denying access.
-- url: /rest/calendar-services/1.0/calendar/events.json | userName: someusername | referer: http://confluence-domain.com/display/HOME/Home
java.lang.IllegalArgumentException: name argument cannot be null
at org.apache.commons.lang.Validate.notNull(Validate.java:192)
Cause
The above mostly commonly is caused by a deleted user from external user management (e.g. LDAP) having created calendar content. Confluence versions before 5.3 were much less resilient to users being missing from directories.
Resolution
- Upgrade to Confluence 5.3.x and above. These versions greatly improve the resilience of Confluence to users that go missing from external user management stores.