Team Calendars for Confluence Performance Problems

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

Confluence pages which contain Team Calendars for Confluence are slow to load.

Diagnosis

  1. Check external factors such as CPU utilisation, and memory allocation on the server to determine whether these are the root cause.
  2. If you use external calendar sources, check whether network slowness could be a contributing factor
  3. Enable Page Profiling and reproduce the issue. Raise a support request and attach a Support Zip to it.

Cause

If there is no external cause and you're still experiencing slowness, it's likely due to a problem which was resolved in Team Calendars for Confluence 2.4. In previous versions, Team Calendars for Confluence collected statistics on calendar subsciptions on page loads, which was not necessary and has been removed. Performance has improved markedly as a result. 

Resolution

  1. Upgrade Confluence to version 4.0 or above.
  2. Upgrade Team Calendars for Confluence to version 2.4 or above.

Last modified on Nov 2, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.