The table plugindata is full
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When try to update plugins, you will see the following in the atlassian-confluence.log
ERROR [pool-19-thread-1] [sf.hibernate.util.JDBCExceptionReporter] logExceptions The table 'PLUGINDATA' is full
Cause
This is due to corrupted plugin cache causing the issue to occur.
Resolution
Clear the plugin cache .This issue can be caused by table size restriction in this case please refer to the knowledge based article Cannot upgrade due to full table in MySQL.