Unable to Access Backup Administration Page Due to Invalid Escape Character

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Symptoms

The following appears in the atlassian-confluence.log:

2012-11-15 19:01:47,722 ERROR [http-8090-2] [[Standalone].[localhost].[/].[action]] log 
Servlet.service() for servlet action threw exception
java.lang.Error: Invalid escape character at line 1 column 5.
	at ognl.JavaCharStream.readChar(JavaCharStream.java:320)
	at ognl.OgnlParserTokenManager.getNextToken(OgnlParserTokenManager.java:1536)

....

Cause

The Backup Path for custom backup contains invalid escape character(s)

Resolution

To fix this, we need to edit the backup path manually in the database:

  • Backup your database
    Run the following SQL query which outputs the BANDANAVALUE all of Confluence settings configured:

    SELECT BANDANAVALUE FROM BANDANA WHERE BANDANAKEY='atlassian.confluence.settings';
    
  • Copy the output of BANDANAVALUE and paste it into Notepad
  • Locate for <backupPath> XML tag. The path is located inside this tag
  • If there are any invalid characters, edit the backup path. Use forward slashes "/" instead.
    To update the backup path, run the following query. Please edit <insert-bandana-value> in the query below from the edited BANDANAVALUE 

    UPDATE BANDANA SET BANDANAVALUE='<insert-bandana-value>' WHERE BANDANAKEY='atlassian.confluence.settings';
  • Go to Confluence Admin > Cache Statistics > Flush All
  • If issue persists after performing the steps above, try to restart Confluence

 


Last modified on Mar 30, 2016

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