Unable to create or edit pages due to blank screen on page editor after an upgrade

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After an upgrade from 5.9.x to 5.10.x, you're unable to create new pages or edit any existing page due to a blank screen on the page editor. This is what you see when you attempt to edit pages:

The following error also appears in atlassian-confluence.log:

2016-08-10 18:27:28,708 ERROR [http-nio-8090-exec-12] [[Standalone].[localhost].[/].[file-server]] log Servlet.service() for servlet file-server threw exception
 -- referer: http://localhost:8090/display/TEST/test+page?src=contextnavpagetreemode | url: /s/f74a31c1389bd48b29b225cd2658d72c-CDN/en_GB/6441/a6dcead450d087fde304eacebd4c0e7a772a5b20/6.1.0/_/download/batch/com.adaptavist.confluence.formMailNG:form-mail-resource/com.adaptavist.confluence.formMailNG:form-mail-resource.js | traceId: 6af0f938813eab54 | userName: admin
java.lang.StackOverflowError
	at java.util.regex.Pattern$BranchConn.match(Pattern.java:4568)
	at java.util.regex.Pattern$BmpCharProperty.match(Pattern.java:3798)
	at java.util.regex.Pattern$Branch.match(Pattern.java:4604)
	at java.util.regex.Pattern$GroupHead.match(Pattern.java:4658)
	at java.util.regex.Pattern$Loop.match(Pattern.java:4785)
	at java.util.regex.Pattern$GroupTail.match(Pattern.java:4717)
	at java.util.regex.Pattern$BranchConn.match(Pattern.java:4568)
	at java.util.regex.Pattern$BmpCharProperty.match(Pattern.java:3798)
	at java.util.regex.Pattern$Branch.match(Pattern.java:4604)
	at java.util.regex.Pattern$GroupHead.match(Pattern.java:4658)
	at java.util.regex.Pattern$Loop.match(Pattern.java:4785)
	at java.util.regex.Pattern$GroupTail.match(Pattern.java:4717)
	at java.util.regex.Pattern$BranchConn.match(Pattern.java:4568)
	at java.util.regex.Pattern$BmpCharProperty.match(Pattern.java:3798)
	at java.util.regex.Pattern$Branch.match(Pattern.java:4604)
	at java.util.regex.Pattern$GroupHead.match(Pattern.java:4658)
...

Diagnosis

  • You have Adaptavist's 'Forms for Confluence' add-on installed in your instance.
  • Clearing plugin cache does not resolve the issue.
  • Adding this JVM parameter when starting up Confluence does not resolve the issue: --jvmargs "-Dis.analytics.enabled=false"
  • Enabling 'Safe Mode' allows you to create and edit pages again.

Cause

Adaptavist's 'Forms for Confluence' is causing this issue to occur.

Workaround

Adaptavist has proposed a workaround to the issue whereby you must set the system property confluence.context.batching.disable to 'true'. By default, it is set to 'false'. 

For more information about this system property, refer to this documentation: Recognized System Properties - confluence.context.batching.disable.

Linux

  1. Edit <Confluence-installation-directory>/bin/setenv.sh.
  2. Find the section CATALINA_OPTS= and add the following line before export CATALINA_OPTS:

    CATALINA_OPTS="confluence.context.batching.disable=true ${CATALINA_OPTS}"

Windows (starting from .bat file)

Note: These instructions are valid if you start Confluence using the .bat file. If you start Confluence using Windows as a Service, please refer to these instructions here: Configure System Properties for Windows Services.

  1. Edit <Confluence-installation-directory>/bin/setenv.bat.
  2. Find the section CATALINA_OPTS= and add the following line:

    set CATALINA_OPTS=confluence.context.batching.disable=true %CATALINA_OPTS%

If the workaround above did not work for you, please contact Adaptavist Support for further assistance.

Last modified on Nov 5, 2017

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