Unable to find a calendar using the search

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Unable to search for a specific calendar, even though it exists and is accessible with its direct link.

Environment

  • Confluence Premium

Diagnosis

This calendar is not returned by the Advanced Search, neither by the search within the Calendar macro.

Cause

This calendar is not correctly indexed on the Instance. 

Solution

Follow below steps, in order to re-index the calendar:

  1. Access the impacted calendar.

  2. Click on Edit, on the top right corner.

  3. Click on OK (perform a dummy update).

This update should re-index this particular calendar, so it should be returned on the search results. To test it, try searching for this calendar, either using the Advanced Search, or using the Team Calendars macro.

Updated on March 21, 2025

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