Unable to save attachments after Confluence upgrade
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After upgrading Confluence, users are unable to save attachments
Environment
- Confluence server and datacenter v7.4.5
- Customware (ServiceRocket) autowatch plugin 1.3.0
Diagnosis
The following stack trace appears in Confluence logs when attaching a file to a Confluence page:
Caused by: java.lang.NoSuchMethodError: 'com.atlassian.confluence.core.ContentEntityObject com.atlassian.confluence.pages.Attachment.getContent()'
at net.customware.confluence.plugin.autowatch.AutowatchListener.handleEvent(AutowatchListener.java:94)
at com.atlassian.event.legacy.LegacyListenerHandler$LegacyListenerInvoker.invoke(LegacyListenerHandler.java:51)
Cause
This issue is caused by a problem within the Customware Servicerocket Autowatch plugin
Solution
- Disable the Autowatch plugin on Confluence Administration → Manage Apps.
- Contact ServiceRocket support.