Unable to Upload / Update a Plugin in the Universal Plugin Manager
Symptoms
User is having trouble uploading a plugin via the Universal Plugin Manager . There is a dialog box than hangs displaying the text "Uploading Plugin XXXX" with a loading gif that does not seem to make any progress.
The following appears in the atlassian-confluence.log
:
com.sun.jersey.server.impl.application.WebApplicationImpl onException
SEVERE: Internal server error
java.lang.RuntimeException: org.apache.commons.fileupload.FileUploadBase$IOFileUploadException: Processing of multipart/form-data request failed. Read timed out
Cause
Communication to the server that is hosting Confluence does not allow uploads from a remote machine. This is especially a limiting factor if Confluence is configured not to allow the Universal Plugin Manager to connect to the Atlassian Marketplace
Resolution
- Log into a web browser on the machine that is hosting Confluence
- Upload the plugin from the host machine