Universal Plugin Manager does not load after update
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Universal Plugin Manager (UPM) was manually upgraded to 4.3.4 and now UPM is not working
Environment
Confluence 6.x and 7.x
UPM 3.0.1
Diagnosis
After upgrading UPM, when you visit General Configuration → Manage Apps (or Gear icon → Manage Apps) you get "page not found":
Cause
UPM was upgraded to an unsupported version. Please see the version history for the UPM which details what versions are designed for what products.
Solution
- Shutdown Confluence (on all nodes if Data Center)
- Run the following SQL query to identify the UPM's rows in the PLUGINDATA table:
SELECT *
FROM plugindata
WHERE pluginkey LIKE '%atlassian-universal-plugin-manager%';
there may be 1 or 2 rows returned depending on the sequence of events that led to this condition - verify all results that were returned relate to the "Universal Plugin Manager", if so, proceed
- Run the following SQL statement to remove them from the database
DELETE
FROM plugindata
WHERE pluginkey LIKE '%atlassian-universal-plugin-manager%';
- Clear the plugins cache (on all nodes if Data Center)
cd <confluence_home_directory>
rm -rf *plugins*
- Start Confluence on one node
- Once Confluence is fully started, navigate to General Configuration -> Manage Apps
- if the the UPM screen loads now, notice that the version of UPM is the original base version (3.0.1)
- Upgrade your UPM to the highest supported version that UPM suggests as an upgrade target version
- If Data Center, start all remaining nodes one at a time